Contest entries
This is Hymenocera Picta a.k.a Harlequin Shrimp. Shoot in at Tulamben  Bali with Canon G16 and strobe Sea Sea YS D2 using DIY snoot with Aquako IV. Trying to make different pose for this and this is it. Dive with my buddy Ajiex Dharma.
By Vincent Christian
posted 12:02 CST Today (within the last hour)
Devil Scorpionfish hiding in the dark.
By Dragos Dumitrescu
posted 11:44 CST Today (1 hour ago)
A small pipefish hiding inside a soft coral
By Fabrizio Torsani
posted 11:13 CST Today (1 hour ago)
Crayfish portrait
By Sigitas Sirvydas
posted 10:50 CST Today (2 hours ago)
Reef Sharks move quick across the healthy reefs of the Bahamas. This image was taken at Tiger Beach off of West End Bahamas
By Steven Anderson
posted 10:46 CST Today (2 hours ago)
Strawberry anemones  a darker shade than usual and a bit smaller.  These were almost a deep orange/red as opposed to the various shades of pinks I normally see.
By Gemma Dry
posted 09:31 CST Today (3 hours ago)


Photo Dive Sites
dive sites latestFakarava south
French Polynesia
dive sites latestFreeport Bahamas
Bahamas, Atlantic
dive sites latestStables
Mozambique, Indian Ocean
dive sites latestcenderawasih bay
Papua New Guinea
dive sites latestRomang
Indonesia, Flores Sea
dive sites latestCaracol Cave
Mexico, Gulf Of Mexico
dive sites latestSeaExplorer, Cabi...
Philippines, Visayan Sea
dive sites latestCross Wreck
Indonesia
dive sites latestWhale Rock
Mauritius, Indian Ocean
dive sites latestPuerto Galera Phi...
Philippines

Search Forums

  infoYou are not logged so will not be able to make forum posts until you login or open a member account
  Really Simple Syndication  
message this message is importantI have a Sony RX100Mii with an Ikelite housing that is not TTL compatible. I have to use fiber optics or an EV Controller. I have a DS200 with the correct EV controller but it does not seem to sync when I take pictures. It does sometimes under water but not always. I have the EV Controller set at 200 and actually tried each setting. I tried the EV controller I have for my 125 and it don't work for the DS200 either. The DS125 works perfectly with the EV controller for the 125. Any suggestions? My next move is to call Ikelite to see if they have any ideas. I tried every setting I can think of and nothing so I will dive tomorrow with the one DS125, which is plenty.
Thanks
 
Jerry Stinnett
238 point member
member image