Contest entries
Soft coral crab. At Romblon  Philippines. By sony 6500.
By Qunyi Zhang
posted 23:07 CST Today (within the last hour)
Squid in the Dark  Gardens of the Queen Cuba
By Alejandro Topete
posted 18:20 CST Today (5 hours ago)
Equipment  Canon 7D mark II 60mm  ulc 6 and PRO Nimar Underwater Housing and Snooty   deep 15mt
By Nadia Chiesi
posted 15:25 CST Today (8 hours ago)
leopard blenny
Date  30/07/2018
Location   ishigaki Japan
Camera   Nikon D850
Housing   Nauticam
Lens   105mm marco 
Strobe   Retra  Retra LSD
Settings   1/200sec  f/25  ISO 250
By Jinggong Zhang
posted 13:14 CST Today (10 hours ago)
Date  15/08/2018
Location   miwura Japan
Camera   Nikon D850
Housing   Nauticam
Lens   105mm marco 
Strobe   Retra  Retra LSD 
Settings   1/250sec  f/29  ISO 100
By Jinggong Zhang
posted 13:09 CST Today (10 hours ago)
backlight story   torny seahorse
By Deniz Muzaffer Gökmen
posted 11:08 CST Today (12 hours ago)


Photo Dive Sites
dive sites latestMasaplod Norte Da...
Philippines
dive sites latestLembeh Strait, In...
Indonesia, Banda Sea
dive sites latestLembeh Strait, In...
Indonesia, Banda Sea
dive sites latestSa Dragonera Isle...
Spain, Balearic Sea
dive sites latestpool cincinnati, ...
United States
dive sites latestBaru Island, Cart...
Colombia, Caribbean Sea
dive sites latestYucatán Dive Trek
Mexico
dive sites latestSantorini
Greece, Mediterranean Sea
dive sites latestSantorini, Greece
Greece, Aegean Sea
dive sites latestMaury Island Quary
United States, Pacific

Search Forums

  infoYou are not logged so will not be able to make forum posts until you login or open a member account
  Really Simple Syndication  
message this message is importantHI, just getting used to my Canon G12 that I purchased in great condition used. Ikelite housing, ikelite double cable, 2 ikelite DS125 strobes. I have had no problem with them syncing, but yesterday after flying to Roatan, the strobes wont sync if power is above 1/4. No matter what mode I shoot in. I have the P mode set up and the C1 and C2 modes set to macro and pan, I tried it on all settings even auto and nothing changes. Wont sync above a 1/4 on the strobe settings. Just got the strobes back from Ikelite having them serviced and all was supposed to be good. NO problems in Cozumel a few weeks ago, didn't drop or anything. I did drop a battery, but it was on a bouncy wood floor and appears to have no damage and it was from about 2-3 feet.
HELP

Jerry
 
Buick48
248 point member
Buick48 member image